Tuesday, May 17, 2011

iBot Tool - Update

The best tool for iBot - International Silkroad Online Bot
Download:
version 2.0.0.0 - iBot Tool - http://adf.ly/431241/ibot-tool
version 2.0.1.0 - iBot Tool - http://adf.ly/431241/ibot-tool
version 2.0.2.0 - iBot Tool - http://adf.ly/431241/ibot-tool

Only use this download link!
NEVER RE-UPLOAD THIS FILE
md5: cd9416b667c47a8a89ed2acedeaa4bd0
This tool isn't made to steal your account.
If you don't trust this, block it in your firewall or don't use it.
Changelog:
  • iBot Tool 2.0
    • Optimized for multiple core cpu's (dual core/quad core etc.)
    • Updated to .NET 4.0 (From .NET 3.5)
    • iBot Tool requires Admin privileges (so a UAC window will pop up if you have Windows Vista or higher, click Yes)
    • Added iBot Manager (Up to 8 chars right now)
      • Get statistics, like HP, MP, XP and more
      • Start/Stop bot
      • Hide/Show bot
      • Start Buffer/Stop Buffer
      • Auto start HS server (be sure you installed it in the same folder as your sro_client)
      • Auto start edxloader (be sure you installed it in the iBot folder!!(iBot Tool is installed there too))
    • Added iBot AutoBuffer
      • Go to Settings --> Config to configure the new AutoBuffer
      • If you configured your AutoBuffer just select the character that have to cast the buffs and click Apply
Bugfix:
  • AutoBuffer is working now :)
  • iBot is "old iBot" again! :D (You only need to start the HackShield yourself.
  • Added some checks for the loader.
  • All launch buttons are working correctly now.


    How to start the HackShield
    Place the HackShield.exe in your Silkroad install file (where SRO_CLIENT is located), launch it as ADMIN (for windows vista/7 users, Right Mouse Button --> Run as admin) Press Launch SRO, just wait until the Client is loaded. Then you can hide it and the HackShield will say: "HackShield is ready". Then launch iBot with iBot Tool and you are done ;)  (You only need 1 HackShield) 



    Note that iBot Tool 2.0 is still in BETA, so please report bugs!
    (There isn't a save function yet, so you have to reconfigure your buffs everytime you restart ibotmanager, working on it ;))

    Unpack the map files in your iBot folder, hold the pictures in the original map! 
    Please report bugs
    You are free to make suggestions
    Thank you
    Note: Place this tool in the same folder as iBot!

    47 comments:

    1. bro please make tutorial... i dont know use =S

      ReplyDelete
    2. Oke, I will make one if i'm back from school, but it isn't that hard to use?

      BTW: I forgot some things, so it don't work really good. Need to fix that :P. And I have to set the ress skill.

      ReplyDelete
    3. God!
      there is 3 autobuffers already .. u don't have to create 1 :D btw good luck in it ^^

      ReplyDelete
    4. Nicely done!!!

      Gonna Check it out after school

      ReplyDelete
    5. suggestion mode client:
      if dc then open again edxloader and auto click launch

      ReplyDelete
    6. @NoN_Stop, I know, but I'll make the best one :D :P

      @juliano, yea I want to make that, but I hadn't much time yesterday :P

      ReplyDelete
    7. EDIT: AutoBuffer isn't working yet (Couldn't test it yesterday cause of DC after 1 minute)

      ReplyDelete
    8. i get error: Net framework !

      ReplyDelete
    9. Because you didn't installed the .NET 4.0 framework ;)

      You can download it here:
      http://www.microsoft.com/downloads/en/details.aspx?familyid=9cfb2d51-5ff4-4491-b0e5-b386f32c0992&displaylang=en

      ReplyDelete
    10. hi dude i think that only character 1 and 2 works the other does not launch!
      Instead of putting all the charac in one window it would be better to open in windows all in another window!Btw great work still some work needed but you need to keep it up!

      ReplyDelete
    11. Yea, i'm still working on it (I think it's fully operational after the weekend :))

      But why should you want to open it in other windows :S, I made this that you have the basic info in 1 window, so you don't have 8 different windows :P.

      ReplyDelete
    12. I get dc after a minute, i portforwarded i use the hackshield server, but still it wont work for long then a minute, do you have a suggestion ?

      ReplyDelete
    13. well done but auto buff not working at all hope to be fixed soon

      ReplyDelete
    14. Vette update denk weer, gebruik nu ff phbot maar als me tijd weg is ga ik weer over naar ibot met je tooltje ;) Wat ga je als volgende doen?

      keep on going

      ReplyDelete
    15. New update! :D Eerst maar eens dit allemaal goed werkend krijgen zonder bugs:P

      ReplyDelete
    16. i cant download! need mediafire

      ReplyDelete
    17. Did you click skip ad after 5 seconds?

      ReplyDelete
    18. hi xtraxx nice tool u have here. i just wanna ask if only character 1 and 2 can use now? i press launch on character 3 but it doesnt work. seems like nothing happen. this is the best add on for ibot at the moments. thanks a lot keep up the good work. :D

      ReplyDelete
    19. bro there is ana problem in the loader can't find media pk2 and the game isn't also the loader working with normal ibot ..... there is an problem in the loader in ibot tools ... client less working but normal client is not working hope to answer me and fix it

      ReplyDelete
    20. if u want to use normal client please use edxsilkroadloader5 included with ibot.
      HERE IS A GUIDE TO USE THIS BOT!

      First off all i have to say that this version of bot isn't better than old versions, but i hope next version will be better! :)

      1- USE OF BOT WITH NORMAL CLIENT

      PRO: You can play and enjoy viewing game in 3d, use taxi and take control easily when you want
      DISADVANTAGE: High CPU use because you will have 2 started client

      HOW TO:
      - Before you start, make sure there is no silkroad running.
      - Extract "[iBot] Edx33Loader + HSServer.rar" to silkroad folder
      - Run PHMediaPatcher.exe
      - Click "Custom" then press "Patch" then "Ok"
      - Close PHMediaPatcher.exe and were done with this setup

      - Run "Hackshield.exe"
      - Click "Launch SRO" and wait till silkroad client launches
      - Don't close silkroad client and HS Server
      -Click Hide/Show SRO

      - Just run "iBot.exe" as you would normally do before
      - You will then see in the status log "HS Server successfully connected!"
      - This tell us that the HS Server has been configured properly

      - Run edxSilkroadLoader5.exe
      - Clic Add
      - Find you sro_client.exe file into your SRO Directory
      - Select: MultiClient, redirect gateway server(127.0.0.1 port 16000), Patch Seed
      Try with or without: NOP HackerShield.
      - Clic Launch!

      Login normally and configure Ibot normally.

      2- USE OF BOT CLIENTLESS
      PRO: Low CPU use because you will have 1 started client in idle
      DISADVANTAGE: You can't play and enjoy viewing game in 3d, can't use taxi and take control easily when you want.
      You have to create a script in 3d mode before use clientless.

      HOW TO:
      - Before you start, make sure there is no silkroad running.
      - Extract "[iBot] Edx33Loader + HSServer.rar" to silkroad folder
      - Run PHMediaPatcher.exe
      - Click "Custom" then press "Patch" then "Ok"
      - Close PHMediaPatcher.exe and were done with this setup

      - Run "Hackshield.exe"
      - Click "Launch SRO" and wait till silkroad client launches
      - Don't close silkroad client and HS Server
      -Click Hide/Show SRO

      - Just run "iBot.exe" as you would normally do before
      - You will then see in the status log "HS Server successfully connected!"
      - This tell us that the HS Server has been configured properly
      - Go to second tab from left
      - Click Connect on the left
      Now will appear all server,select you server

      *Name: you char name in game
      *Autoselect character
      *Autostart Bot
      *Server: your server (At start you can't select any server)
      *User: your login
      *Password: your password
      *Auto relog

      credit goes to someone who post this on http://ibotforfun.blogspot.com

      ReplyDelete
    21. All this i know i used loader and it works normaly even in ibot tools 2.00 but in ibot tools 2.01 there is ana problem in loader

      ReplyDelete
    22. Yea sorry, I forgot to add the launch buttons to my code (EPIC FAIL :P) I'll release a new version if I'm back from school.

      @The loader problem, did you place it in the ibot folder? And is your srodir.ini right (You can select your sro_client with ibot tools.(Options-->set silkroad folder). Then it should work. (Also don't forget to patch your media.pk2, place the phmediapatcher in your sro folder!)

      ReplyDelete
    23. Haha, you don't have to wait, I released it now :D

      ReplyDelete
    24. reporting bug

      1. only first launcher will show HP changes but that also buggy since its changing very fast like 2times in 1 sec.

      still didnt try the auto buffer since i cant login my goldbots using ibot because ip limit 5. need to create more ibots folders for different proxy and also cant use ibot launcher for proxies.

      suggestion

      1 - use opensource proxy application and add it to ibot tool so we can select config and select proxy to use for it. xD just a suggestion dunno anything about programming tho.

      great tool came from great people. Im sure you are younger than me since you are still in school (college i assume) but your awesomeness defeat me by 10 level.

      thanx xTraXx

      ReplyDelete
    25. btw i am SQuinTeX. got 2 google account didn remember i post with different account before. sry

      ReplyDelete
    26. Man how can i start more ibots with this ibottool... if i have only 1 charconfig in my ibot folder.... OMG MAKE A TUTORIAL PLEASE

      ReplyDelete
    27. bro i dont know why dont run tool me =(..
      for example i have 2 char in pt...
      1) launch char for ibot auto buff... http://i52.tinypic.com/9r7y1f.jpg
      2) for example i want dafne give mana cicle, so i configure http://i54.tinypic.com/v2y74i.jpg
      and make APPLY
      3)after i make star buff and star bot... and char dont give buff ¬¬
      so WHAT I MAKE BAD?

      ReplyDelete
    28. Xr1 Blaz said...

      Man how can i start more ibots with this ibottool... if i have only 1 charconfig in my ibot folder.... OMG MAKE A TUTORIAL PLEASE

      after you press the button launch, just put your login id and password for your next character and enter the character name and press Launch ibot. this is just one time setting. after that in select config will appear the other chars u have in ibot folder.

      ReplyDelete
    29. Thanks for the feedback I'll look at it, if I can find any bugs!

      ReplyDelete
    30. Oh, if you want to buff you don't have to click start bot(then you will go attack mobs)

      ReplyDelete
    31. :D... now run perfect XD..... thanxx

      ReplyDelete
    32. Tomorrow big bugfix update :P (Sorry for the shitload of bugs.. couldn't test it well, due to a lack of time)

      ReplyDelete
    33. i make set silk road from options and choose sro_client and he keep telling plz set silk road i dunno why ?? could u tell me what to do

      ReplyDelete
    34. i have a question... how to run 4 ibots with the ibot tool? how could it find the right config? Do i have to but all my configs in a other folder?

      ReplyDelete
    35. Nono, the config is only a save file of your login information, so if you entered it once, you don't have to do it any more ;). You just select your character then. So if you have a new character, just ignore the config.

      I saw that iBot Tool was buggy with launching multiple iBots, so I'm working on a new version.

      ReplyDelete
    36. hi xTraXx, just want to ask a few questions..Is the client will automatically hide itself after i successfully log-on to the game? I'm just curious mate because this is my first time to use the ibot-tool forgive for asking if i ask lot of questions.^_^

      ReplyDelete
    37. how can i control my char mate if i cannot see my character moving.^_^

      ReplyDelete
    38. BROOO ... every time i try to log in >>it work great .. till chosing the character ... then client give me >>> Failed to connect to server error (s1035) need your help .. isabila_9999@yahoo.com

      ReplyDelete
    39. Please post comments in the newest update log.

      ReplyDelete
    40. hi xxtraxx great work BUT

      i cant make it to work, im getting the "ibot window not found" error...

      1. i start HS (sro folder)
      2. sro.exe
      3. launch ibot with ibot tools
      -edxloader (bot folder)
      -hs server (bot folder)

      **i use the latest ibot, win7

      ReplyDelete
    41. Hey bro im having problems. im running 6 accs same time 4 atackers 2 buffer all good but in a few minuts the ibot tool close itselft i mean it banish.. ibot still working but the tools isnt there anymore : P

      ReplyDelete
    42. This comment has been removed by the author.

      ReplyDelete
    43. Thanks!
      but I have a problem, how to make when the character (warrior) to change weapon to use recovert division and then change weapon to buff the warrior?

      ReplyDelete
    44. why i use ibot got dc any munites

      ReplyDelete
    45. it always says the ibot tool isn't compatible with my ibot version. I've got the latest version of both programs. How can I fix this? Thanks

      ReplyDelete
    46. i had some problems from before since i'm using windows 7 but after getting through those i got it to work but its not letting me log in after i enter username and pass and hit connect it just sticks

      ReplyDelete